use strict;
my $str = '(quote.AGE was 24 AND (application.path = "**\\acad.exe" OR application.path = "**\\dxfdwg.exe" OR application.path = "**\\EXCELSIOR.EXE" OR application.path = "**\\iges.exe" OR application.path = "**\\notepad.exe" OR application.path = "**\\run_journal.exe" OR application.path = "**\\AcroRd32.exe" OR application.path = "**\\dllhost.exe" OR application.path = "**\\powerpnt.exe" OR application.path = "**\\Edge.exe" OR application.path = "**\\step203ug.exe" OR application.path = "**\\step214ug.exe" OR application.path = "**\\VisView.exe" OR application.path = "**\\Teamcenter.exe" OR application.path = "**\\ug_convert_part.exe" OR application.path = "**\\ugraf.exe" OR application.path = "**\\ugtopv.exe" OR application.path = "**\\wmplayer.exe" OR application.path = "**\\winword.exe" OR application.path = "**\\wordpad.exe" OR application.path = "**\\vlc.exe" OR application.path = "**\\dwgviewr.exe" OR application.name = "RMS" OR application.path = "**\\acrobat.exe" OR application.path = "**\\Alias.exe" OR application.path = "**\\awtessd.exe" OR application.path = "**\\proe.exe" OR application.path = "**\\STPViewer.exe" OR application.path = "**\\gom_inspect.exe" OR application.path = "**\\gom_cad_server2.exe" OR application.path = "**\\sldworks.exe" OR application.path = "**\\sldworks_fs.exe" OR application.path = "**\\sldProcMon.exe" OR application.path = "**\\AdapplicationMgr.exe" OR application.path = "**\\AdapplicationMgrSvc.exe" OR application.path = "**\\SE3Dtrans.exe" OR application.path = "**\\stamp.exe" OR application.path = "**\\psolid.exe" OR application.path = "**\\mpid.exe" OR application.path = "**\\mpirun.exe" OR application.path = "**\\FS.exe" OR application.path = "**\\xtop.exe" OR application.path = "**\\pro_comm_msg.exe" OR application.path = "**\\nmsd.exe" OR application.path = "**\\creoagent.exe" OR application.path = "**\\parametric.exe" OR application.path = "**\\PDFEditor.exe" OR application.path = "**\\CNEXT.exe" OR application.path = "**\\drafter.exe" OR application.path = "**\\convert.exe" OR application.path = "**\\ActCut3D.exe" OR application.path = "**\\ppcbasic.exe" OR application.path = "**\\deltamesh_stamping.exe" OR application.path = "Xasfsf" OR application.path = "sfdsdf"))';
my $regex = qr/(.*?\"\s+)\bOR\b(\s+application.*?)/mp;
my $subst = '$1||$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";