import Foundation
let pattern = #"((asia|europe|us|australia)|((north|south)(america|africa)))-((east|west|central|north|south)|((north|south)(east)))([0-9]{1,2})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
(east|west|central|north)?(north|south)?(east)[0-9]{1,2}
(east|west|central|north)(north|south)(east)[0-9]{1,2}
(north|south)(america)
FireStore Regions
us-west1 oregon
us-west2 Los Angeles
us-west3 Tuz Gölü şehri
us-west4 Las Vegas
northamerica-northeast1 Montreal
northafrica-west3
southafrica-east1
us-east1 Güney Carolina
us-east4 Kuzey Virginia
southamerica-east1 Sao Paulo
europe-west2 Londra
europe-west4
europe-west3 Frankfurt
europe-central2 Varşova
europe-west6 Zürih
asia-south1 Bombay
asia-southeast1 Singapur
asia-southeast2 Cakarta
asia-east2 Hong Kong
asia-east1 Tayvan
asia-northeast1 Tokyo
asia-northeast2 Osaka
asia-northeast3 Seul
australia-southeast1 Sidney
australia-southeast2
australia-southeast
Function Regions
asia-east1 (Tayvan)
asia-east2 (Hong Kong)
asia-northeast1 (Tokyo)
asia-northeast2 (Osaka)
europe-west1 (Belçika)
europe-west2 (Londra)
us-central1 (Iowa)
us-east1 (Güney Karolina)
us-east4 (Kuzey Virginia)
us-west1 (Oregon)
asia-northeast3 (Seul)
asia-southeast1 (Singapur)
asia-southeast2 (Cakarta)
asia-south1 (Mumbai)
australia-southeast1 (Sidney)
europe-central2 (Varşova)
europe-west3 (Frankfurt)
europe-west6 (Zürih)
northamerica-northeast1 (Montreal)
southamerica-east1 (Sao Paulo)
us-west2 (Los Angeles)
us-west3 (Salt Lake City)
us-west4 (Las Vegas)
asia-east1 (Tayvan) us-west2 (Los Angeles) europe-west1 (Belçika)
us-west3 (Salt Lake City) asia-northeast1 (Tokyo) southamerica-east1 (Sao Paulo)
us-west4 (Las Vegas) asia-east2 (Hong Kong) northamerica-northeast1 (Montreal)
europe-west2 (Londra) asia-south1 (Mumbai) europe-west3 (Frankfurt)
us-central1 (Iowa) europe-central2 (Varşova) europe-west6 (Zürih)
us-east1 (Güney Karolina)
asia-northeast3 (Seul)
us-east4 (Kuzey Virginia)
australia-southeast1 (Sidney)
us-west1 (Oregon)
asia-southeast2 (Cakarta)
asia-southeast1 (Singapur)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)