import re
regex = re.compile(r"^(?<prefix>-{0,2}[A-Za-z\s_\-:]+)?(?<version>\d+)(?<sufix>.+)$", flags=re.MULTILINE)
test_str = ("sc_1-file\n"
"sc_2-file\n"
"sc_3-file\n"
"sc_4-file\n"
"sc_5-file\n"
"sc_6-file\n"
"sc_7-file\n"
"sc_8-file\n"
"sc_9-file\n"
"sc_10-file")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")