re = /^(?<prefix>-{0,2}[A-Za-z\s_\-:]+)?(?<version>\d+)(?<sufix>.+)$/m
str = 'sc_1-file
sc_2-file
sc_3-file
sc_4-file
sc_5-file
sc_6-file
sc_7-file
sc_8-file
sc_9-file
sc_10-file'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end