package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[\[(.+?)\]\]`)
var str = `mSurface=Surface(name=com.[[letter]]bbk.launcher2/com.[[bbk]].launcher2.Launcher)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}