re = /\[\[(.+?)\]\]/m
str = 'mSurface=Surface(name=com.[[letter]]bbk.launcher2/com.[[bbk]].launcher2.Launcher)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end