using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:apples|pears|bananas)(?:(?:\s+(?:or|and)\s+|\s*,\s*)+(?:apples|pears|bananas))*";
string substitution = @"[\g<0>]";
string input = @"apples, pears, bananas are fruit
pears, apples, and bananas are in the fruit basket
you can use bananas, pears, and apples in a fruit salad
he also likes pears, bananas, and apples for a snack
she likes cheese for a snack but also apples or pears";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}