import re
regex = re.compile(r"\b(?:apples|pears|bananas)(?:(?:\s+(?:or|and)\s+|\s*,\s*)+(?:apples|pears|bananas))*", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("apples, pears, bananas are fruit\n\n"
"pears, apples, and bananas are in the fruit basket\n\n"
"you can use bananas, pears, and apples in a fruit salad\n\n"
"he also likes pears, bananas, and apples for a snack\n\n"
"she likes cheese for a snack but also apples or pears")
subst = "[\\g<0>]"
result = regex.sub(subst, test_str)
if result:
print(result)