import re
regex = re.compile(r"\d*\.?,?\d+|[\*\-\+\/\(\)\$]", flags=re.IGNORECASE)
test_str = ("$( 10 * 10.65 ) - 30\n"
"$(10*10,65)-(30+2)\n"
"$(10*10.0)-30\n"
"(10*10.0)-30\n"
"10 10.65 * $ 30 -\n"
"100 + 1\n"
"1 + 1\n"
"1 1 +\n"
"8 + 8 / 4")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")