$re = '/(.*?)#\$(.*?)#\$(.*?)#\$(.*?)#\$(.*?)#\$(.*)/m';
$str = '1234#$CSI#$MAN # NO#$MANN#$1212#$N';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);