re = /(.*?)#\$(.*?)#\$(.*?)#\$(.*?)#\$(.*?)#\$(.*)/m
str = '1234#$CSI#$MAN # NO#$MANN#$1212#$N'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end