$re = '/(?<!\\\\)(?:\\\\{2})*_(?:[^\\\\_\n]|\\\\.)+_/m';
$str = 'So, this would be a match: _italic some text 123 \\_*%&$ _
\\_test_test_';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);