re = /(?<!\\)(?:\\{2})*_(?:[^\\_\n]|\\.)+_/m
str = 'So, this would be a match: _italic some text 123 \\_*%&$ _
\\_test_test_'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end