using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+).? ([\w ]*) ?(?>\((.*)\) (.*))?";
string input = @"1 Ripe Avocado
1x Ripe Avocado
1 Ripe Avocado (lrg) 123
1x Ripe Avocado (lrg) 123";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}