re = /(\d+).? ([\w ]*) ?(?>\((.*)\) (.*))?/m
str = '1 Ripe Avocado
1x Ripe Avocado
1 Ripe Avocado (lrg) 123
1x Ripe Avocado (lrg) 123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end