#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\w+(?:, *\w+)*$"
Local $sString = "one" & @CRLF & _
"one, two" & @CRLF & _
"один" & @CRLF & _
"один, два" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"one," & @CRLF & _
"один," & @CRLF & _
"one two" & @CRLF & _
"один два" & @CRLF & _
"one, two," & @CRLF & _
"один, два,"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")