package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\w+(?:, *\w+)*$`)
var str = `one
one, two
один
один, два
one,
один,
one two
один два
one, two,
один, два,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}