package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\<published\>\d\d\d\d-\d\d-\d\dT)\d\d:\d\d:\d\d\.\d\d\d(\+\d\d:\d\d\<\/published\>)`)
var str = `<published>2019-01-03T23:54:00.000+10:00</published>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}