import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\<published\\>\\d\\d\\d\\d-\\d\\d-\\d\\dT)\\d\\d:\\d\\d:\\d\\d\\.\\d\\d\\d(\\+\\d\\d:\\d\\d\\<\\/published\\>)";
final String string = "<published>2019-01-03T23:54:00.000+10:00</published>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}