const regex = /\b(bananas|mangoes|plums)\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(bananas|mangoes|plums)\\b', 'gm')
const str = `Ben likes bananas. I have got a banana.
Ben likes mangoes. I have got a mango.
Ben likes plums. I have got a plum.
Ben likes oranges. I have got an orange.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}