$re = '/\b(bananas|mangoes|plums)\b/m';
$str = 'Ben likes bananas. I have got a banana.
Ben likes mangoes. I have got a mango.
Ben likes plums. I have got a plum.
Ben likes oranges. I have got an orange.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);