#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xs)(?(DEFINE)" & @CRLF & _
" (?<block>" & @CRLF & _
" \{ # Match opening brace" & @CRLF & _
" (?: # Start non-capturing group" & @CRLF & _
" [^{}]++ # Match non-brace characters without backtracking" & @CRLF & _
" | # or" & @CRLF & _
" (?&block) # Recursively match the last captured group" & @CRLF & _
" )* # Match 0 or more times" & @CRLF & _
" \} # Match closing brace" & @CRLF & _
" )" & @CRLF & _
")(.+?)(?&block)(.+)"
Local $sString = "use strict;" & @CRLF & _
"use warnings;" & @CRLF & _
"" & @CRLF & _
"my $text = << "END";" & @CRLF & _
"int max(int x, int y)" & @CRLF & _
"{" & @CRLF & _
" if (x > y)" & @CRLF & _
" {" & @CRLF & _
" return x;" & @CRLF & _
" }" & @CRLF & _
" else" & @CRLF & _
" {" & @CRLF & _
" return y;" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
"// something here" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")