import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?(DEFINE)\n"
+ " (?<block>\n"
+ " \\{ # Match opening brace\n"
+ " (?: # Start non-capturing group\n"
+ " [^\\{\\}]++ # Match non-brace characters without backtracking\n"
+ " | # or\n"
+ " (?&block) # Recursively match the last captured group\n"
+ " )* # Match 0 or more times\n"
+ " \\} # Match closing brace\n"
+ " )\n"
+ ")(.+?)(?&block)(.+)";
final String string = "use strict;\n"
+ "use warnings;\n\n"
+ "my $text = << \"END\";\n"
+ "int max(int x, int y)\n"
+ "{\n"
+ " if (x > y)\n"
+ " {\n"
+ " return x;\n"
+ " }\n"
+ " else\n"
+ " {\n"
+ " return y;\n"
+ " }\n"
+ "}\n"
+ "// something here\n";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}