using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^\s:]+):(?:\[([^][]+)]|(\S+))";
string input = @"key1:value1 key#2:@value#2 nyet key3:[@value#3, value4] key4:[value5] :bar
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}