package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^\s:]+):(?:\[([^][]+)]|(\S+))`)
var str = `key1:value1 key#2:@value#2 nyet key3:[@value#3, value4] key4:[value5] :bar
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}