using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<sup id=""fnref:\d+"".*?</sup>";
string substitution = @"";
string input = @"<p>A footnote<sup id=""fnref:1""><a href=""#fn:1"" class=""footnote-ref"" role=""doc-noteref"">1</a></sup> here. A superscript<sup>®</sup> after it.</p>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}