use strict;
my $str = '<p>A footnote<sup id="fnref:1"><a href="#fn:1" class="footnote-ref" role="doc-noteref">1</a></sup> here. A superscript<sup>®</sup> after it.</p>';
my $regex = qr`<sup id="fnref:\d+".*?</sup>`mp;
my $subst = '';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";