const regex = new RegExp('\\((.+?)\\)\\s*(OR|AND)?', 'gm')
const str = `(f = '1' OR f = '2') AND (s = '3' OR s = '4' OR s = '5') AND (t = '6')
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}