import re
regex = re.compile(r"\((.+?)\)\s*(OR|AND)?", flags=re.MULTILINE)
test_str = ("(f = '1' OR f = '2') AND (s = '3' OR s = '4' OR s = '5') AND (t = '6')\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")