$re = '/^[A-Za-z\s]{1,16}$/m';
$str = 'Abc Abc
Abc Abc1
AbcAbcAbcAbcAbcAbc
AbcAbcAbc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);