// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[A-Za-z\s]{1,16}$").unwrap();
let string = "Abc Abc
Abc Abc1
AbcAbcAbcAbcAbcAbc
AbcAbcAbc";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}