import re
regex = re.compile(r"(?:([^;]*);){23}", flags=re.MULTILINE)
test_str = "57423543521;314743352134;Source;Tue Apr 02 12:32:44 BST 2019;ELIGIBILITY;ABC345;MyChannel;DUMBRE;1;RR87835;NM;2019-04-02T07:20:00.000Z;VV;;;M;N;XCB234657;;24234SDF4435345;MrNitinDumbre;N;N;DFD4546;Adult;;MYTICKET;4535435435;;657657655;PP;N;Y;;Y;;N;;;Unconfirmed;;;Not Performed;OK;;Not Known"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")