$re = '/start/ms';
$str = 'start
Sample text 1!
...Sample text 2?
!, Sample text 3
&Sample text 4&
...
end';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);