re = /start/m
str = 'start
Sample text 1!
...Sample text 2?
!, Sample text 3
&Sample text 4&
...
end'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end