$re = '/^[A-Z](?:[a-zA-Z]|(?:(?<![ .\'-])[ .\'-](?![ .\'-])))*[a-z]$/m';
$str = 'John
Jean-Pierre
Smith.Rowe
Harry Smith
john
Jean--Pierre
Smith.-Rowe
Harry Smith';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);