re = /^[A-Z](?:[a-zA-Z]|(?:(?<![ .'-])[ .'-](?![ .'-])))*[a-z]$/m
str = 'John
Jean-Pierre
Smith.Rowe
Harry Smith
john
Jean--Pierre
Smith.-Rowe
Harry Smith'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end