$re = '/(\w+\.)?(facebook|twitter|instagram|youtube|pinterest)\..+/m';
$str = 'www.m.facebook.com
facebook.com.au
m.facebook.com
twitter.com
I.instagram.com
youtube.com/v=ch82e98u1
m.youtube.com
pinterest.com
m.pinterest.com
m.pinterest.com.au
pinterest.com.au
m.google.com';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;