# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\w+\.)?(facebook|twitter|instagram|youtube|pinterest)\..+"
test_str = ("www.m.facebook.com\n"
"facebook.com.au\n"
"m.facebook.com\n"
"twitter.com\n"
"I.instagram.com\n"
"youtube.com/v=ch82e98u1\n"
"m.youtube.com\n"
"pinterest.com\n"
"m.pinterest.com\n"
"m.pinterest.com.au\n"
"pinterest.com.au\n"
"m.google.com")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.