package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Sent:\s*([^\n\r]*) To:`)
var str = `From: Y Sent: Monday, November 6, 2018 6:38 AM To: X
BLA BLA
Thank you,
From: X Sent: Monday, November 5, 2018 8:38 AM To: Y
Hi Y BLA
Thanks,`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}