re = /Sent:\s*([^\n\r]*) To:/
str = 'From: Y Sent: Monday, November 6, 2018 6:38 AM To: X
BLA BLA
Thank you,
From: X Sent: Monday, November 5, 2018 8:38 AM To: Y
Hi Y BLA
Thanks,'
# Print the match result
str.match(re) do |match|
puts match.to_s
end