package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[.*Cell01.*\]`)
var str = `Some_String_That_ineed_01[ifcontainsCell01removehere],xxxxxxxxx02`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}