$re = '/\[.*Cell01.*\]/m';
$str = 'Some_String_That_ineed_01[ifcontainsCell01removehere],xxxxxxxxx02';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);