$re = '/((-?([1-9][0-9]*)?\.([1-9][0-9]*)?)|(0|-?([1-9][0-9]*)|-))?ȷ((-?([1-9][0-9]*)?\.([1-9][0-9]*)?)|(0|-?([1-9][0-9]*)|-))?/';
$str = 'ȷ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);