re = /((-?([1-9][0-9]*)?\.([1-9][0-9]*)?)|(0|-?([1-9][0-9]*)|-))?ȷ((-?([1-9][0-9]*)?\.([1-9][0-9]*)?)|(0|-?([1-9][0-9]*)|-))?/
str = 'ȷ'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end