package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([0-9]+(?:\.[0-9]+)?|[+]|[*]|[0-9]+)|\S+`)
var str = `45 + 31.05 * 110 @ 54`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}