$re = '/([0-9]+(?:\.[0-9]+)?|[+]|[*]|[0-9]+)|\S+/m';
$str = '45 + 31.05 * 110 @ 54';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);