const regex = /(?<=^|\s)[^0-9].*?(?=$|\s)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=^|\\s)[^0-9].*?(?=$|\\s)', 'gm')
const str = `black PENS Assorted Bit Set 10Pcs
Hollow blocks 10-16mm Cd3
Hollow blocks 16-23mm Cd3
Hollow blocks 5-10mm Cd3
Hollow blocks To 1-5mm Cd3 a10-333
\\b[^0-9\\s].*?\\b`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}