re = /(?<=^|\s)[^0-9].*?(?=$|\s)/m
str = 'black PENS Assorted Bit Set 10Pcs
Hollow blocks 10-16mm Cd3
Hollow blocks 16-23mm Cd3
Hollow blocks 5-10mm Cd3
Hollow blocks To 1-5mm Cd3 a10-333
\\b[^0-9\\s].*?\\b'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end