using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^vm/3\d{2}$";
string input = @"vm/300
vm/399
vm/1337";
RegexOptions options = RegexOptions.Multiline | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}