package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^vm/3\d{2}$`)
var str = `vm/300
vm/399
vm/1337`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}